bareBård

Ettermontering av Webasto i F11

Recommended Posts

Dette kan bli en DIY-tråd eller en katastrofe.

Jeg hadde egentlig bestemt meg for at min neste bil skulle ha Webasto e.l.
Men så dukket denne F11'en opp med riktig motor, fornuftig pris og pen utstyrspakke bortsett fra at den manglet Webasto. 
Jeg kjøpte bilen likevel.

Noen dager senere reiste jeg på jobb til sjøs. Der hadde jeg god tid og jeg ble sittende å tenke på denne Webastoen som manglet.
Etterhvert begynte jeg å studere delekataloger. Det originale retrofit-settet (64502222636) til over 15.000kr synes jeg ble for dyrt, men det så ut som en overkommelig jobb å montere delene.
Mens jeg fortsatt var til havs, altså uten å ha sett på min egen bil, tok jeg sjansen på å bestille en brukt Thermo Top VEVO fra F11 på et svensk huggeri. Jeg kunne fått den samme varmeren betydelig billigere fra en annen bilmodell, men nå fikk jeg med riktige braketter, sirkulasjonspumpe. magnetventil, eksos og diverse slanger. Alt skal forhåpentligvis passe rett inn.
Jeg skaffet også dieselpumpe fra Touran med samme varmer og en pakke med dieselslange og koblinger.

20161115_201313+_Large_.jpg20161115_201343+_Large_.jpg

Da jeg kom hjem reiste jeg på Bilia og fikk tak i monteringsanvisningen til det originale retrofit-settet fra Aftersales Assistance Portal.
Der var det mye interesant lesning.

Bl.a. ser det ut som det følger med nye tåkelys i settet. Det kan jo tyde på at originale lys (som jeg har) kommer i konflikt med varmeren. Snodig. Jeg finner bare en type tåkelys i katalogene ellers.
Her må jeg vl bare prøve å se.

Det står også at det følger med ny tankarmatur i settet. Det likte jeg ikke. Jeg håpet den originale var forberedt for ekstra uttak.
Jeg demonterte baksetet og inspeksjonsluka. Der fant jeg et blendet uttak som så veldig fint ut.
Hurtigkoblingen fra Touran passet rett på :-)

20161119_124226+_Large_.jpg

Jeg håper jeg skal klare å tilpasse vannslangene på bilen med litt universaldeler som jeg har liggende. 
Da tror jeg det eneste jeg mangler er ledningsnett. Det er bestilt (nytt, originalt, 61122222756).
Jeg prøvde først å finne løse kontakter, det er jo ikke så mange ledninger, men jeg gikk heller for originalt og pent da jeg oppdaget at det var mulig å skaffe.

Ledningsnettet kommer forhåpentligvis på tirsdag. Da blir det montering så fort som mulig, før det blir skikkelig kaldt.
Jeg skal prøve å dokumentere underveis.

 

I min forrige bil hadde jeg Eberspächer med hjemmelaget SMS-styring. BMWen kan ikke være noe dårligere.
Det blir episode 2....

Redigert av bareBård

Del dette innlegget


Link til innlegg
Del på andre sider

Litt spennende med deler fra litt av hvert. 

Jeg safet på min e61 og kjøpte alt originalt, men mye brukt. Var en god del arbeid, men verdt det i ettertid. 

Lykke til 

Del dette innlegget


Link til innlegg
Del på andre sider
7 minutter siden, Otis skrev:

Litt spennende med deler fra litt av hvert. 

Det er ikke så ille. Dieselpumpa er original Webesto med riktig Webasto-nummer, den har bare VAG-nummer i tillegg.

Det er bare slanger som er universal.

7 minutter siden, Otis skrev:

Lykke til 

Takk.

Del dette innlegget


Link til innlegg
Del på andre sider

20161128_225631+_Large_.jpg

Da har ledningsnettet og den siste braketten dukket opp. Nettet er veldig mye penere enn det jeg kunne laget selv.

20161127_191214+_Large_.jpg

Jeg koblet vakuumpumpe på det ekstra uttaket på dieseltanken. Da fikk jeg lett pumpet opp diesel. Fine greier.

20161127_012052+_Large_.jpg

Jeg har også tatt en sjekk av varmeren. Webasto bruker samme interface som diagnoseporten på litt eldre VAG. Derfor kunne jeg bruke en billig 'VAG-COM'-kabel sammen med Webastos egen ThermoTest-software.
Ting så bra ut. En lagret feilkode, men det så ikke alvorlig ut. Jeg fikk testkjørt vannpumpe, vifte osv.
I følge statistikken har den gått 30 timer som parkeringsvarmer og litt kortere som tilleggsvarmer. Artig.

Del dette innlegget


Link til innlegg
Del på andre sider

Du bør sjekke at røret du kobler sugeslangen til på tankarmaturet har sugerør som går helt ned til bunn av tanken. På f.eks volvo som jeg jobber med, så putter man ett sugerør med gummipakning på toppen når man skal ta ibruk det ekstra uttaket på armaturet. Dette sugerøret holdes på plass når man klikker på slangen.

En annen ting du bør gjøre før du monterer den, er å skru av braketten som holder den fast i bilen, og smøre de 3(?) boltene. Spesielt den som er ved eksosutløpet, pleier å ruste fast skikkelig pga store temperatursvingninger og stål mot alu.

Blir spennede å følge, lykke til!

Del dette innlegget


Link til innlegg
Del på andre sider

Varmeren kom på plass for et par uker siden og har vært i full drift etterpå.
Alt fungerte på første forsøk. :-D

Dette var en stor jobb. BMW sier 9,5 time.
Vi brukte nesten 25 arbeidstimer og vi tok noen snarveier.
2 mann, 2 økter av 5 timer. Til slutt brukte jeg nesten 5 timer alene på finpussen.
Vi gjorde hele jobben på 4-søylers bukk, bortsett fra kabling innvendig. Det fungerte bra. 2-søyler hadde nok vært enda litt bedre.
Jeg fikk dessverre ikke tatt så mange bilder som jeg hadde planlagt.

I følge manualen til BMW skal man demontere dieseltanken (+ eksos og mellomaksling). Det ble for mye jobb for meg.
Vi bare tredde røret (universal 2-4mm) ned fra inspeksjonsluka og over på førersiden. Dieselpumpa plasserte vi på original plassering foran tanken. Festet med en enkel P-klemme.
Tankarmaturen hadde et ekstra uttak og det fungerte uten noe ekstra jobb. Jeg åpnet aldri tanken. Denne bilen fikk nylig ny matepumpe på garanti, så det er mulig delene ikke er som originale.
Røret fremmover la vi langs de eksisterende dieselrørene, de originale klipsene hadde spor som var beregnet til dette. Ledningen bakover til pumpe la vi samme sted.

20161231_125632+_Large_.jpg20161231_122846+_Large_.jpg

Fremme demonterte vi støtfangerdeksel, venstre innerskjerm og alle deksler på undersiden.
Vi demonterte den elektriske sirkulasjonspumpen (skulle ikke bruks lenger) og tappet frostvæsken den veien. Etter det sluttet å renne der var slangene som skulle byttes så godt som tomme.
Jeg var veldig glad for at jeg kjøpte fullt sett originale slanger. De hadde riktige bøyer og forsterkninger på riktig sted, de la seg pent akkurat der de skulle være.
For å få på plass returen fra varmeapparatregisteret helt inne på torpedoveggen måtte vi demontere vindusviskermotoren og mye deksler. Mye verre enn jeg hadde sett for meg.
Selve varmeren smatt lett på plass med ny original brakett. Det ble litt fikling med luftkanalen til bremsene (M-sport fanger), men ikke noe stor sak.

20161230_202307+_Large_.jpg20161230_202649+_Large_.jpg
20161231_113004+_Large_.jpgslanger+N57.PNG

Vi startet med ledningsnettet i motorrommet. Kontaktene til varmeren tredde vi ned og ut langs vannslangene. Det var et eksisterende jordingspunkt rett bak varmeren som fungerte bra. Ledningene til dieselpumpa la vi ned på innsiden av innerskjermen og bakover sammen med dieselrøret. Pluss- og datakabel la vi under sidedekslene i motorrommet og gjennom torpedoveggen helt ute ved A-stolpen. Det er en stor kabelgjennomføring der fra før, og jeg lagde et nytt hull i gummien godt unna eksisterende kabler. Det var vanskeligere enn forventet, fyktelig tykk gummi.
Begge kablene la jeg tvers over innsiden av torpedoveggen. Plusskablen gikk videre bakover på passasjersiden til sikringsboksen helt bak. Datakabelen dyttet jeg inn i eksisterende kontakthus på 'junction box'. Derfra måtte jeg dra en annen kabel (samme farge) over til klimapanelet. Jeg mistenker at jeg ikke hadde trengt å gå via 'junction box', men det er jo greit at det stemmer med skjemaet.

kabling2.PNGkabling.PNGgjennomf__ring.PNG

I ESYS la jeg inn 536 i FA og kodet alle relevante moduler. Da dukket 'auxilary heater' opp i menyen og dieselpumpa begynte å tikke da jeg aktiverte den. På de 2 første forsøkene stoppet pumpa etter noen minutter. Rett før den stoppet andre gangen så jeg at det begynte å komme diesel i røret fremme (fordelen med klart rør, ikke org. svart). På tredje forsøk startet varmeren og gikk fint. 

Jeg har ennå ikke fått laget til fjernkontroll, men som kjørevarmer fungerer den utmerket.
Tredje dagen etter montering fikk vi -15°C og jeg hadde varm luft etter noen få minutter.

Del dette innlegget


Link til innlegg
Del på andre sider

For en stund siden fikk jeg ordnet fjernkontroll til Webastoen.
Original kontroll koster nesten 2000kr og jeg synes det er upraktisk å bære med seg en ekstra.
Da må man finne opp litt.

Jeg lyttet litt på bussen (K-CAN1) og fant ut hvilken melding som blir sendt når man starter varmeren fra iDrive (ID 0x2A2 - 0x06FC). Jeg fant også meldingen som går når man trykker knapp 3 på den vanlige fjernkontrollen. Kort trykk på denne knappen har vanligvis ingen funksjon, men må holde den inne for å åpne den lille bakluka. Så programmerte jeg en Arduino til å lytte etter riktig melding og sende start/stopp. Det fungerer fint, men i neste versjon skal jeg legge inn noe slags tilbakemelding med lysene, slik at jeg ser om den mottok signalet. Foreløpig koblet jeg meg bare inn på kontakten til hengermodulen, det var en grei plass å finne buss og terminal 30.

20170219_140830+_Large_.jpg

 

Redigert av bareBård

Del dette innlegget


Link til innlegg
Del på andre sider

@bareBård Det var egentlig jævlig kult! Virker det bare ellers mht strømtrekk og at du ikke får feilmeldinger og slikt? Jeg mener at bilen må vite at modulen for fjernkontroll er i bilen ellers kutter den strømmen til denne modulen ved dvale.

Del dette innlegget


Link til innlegg
Del på andre sider
On 22.2.2017 at 11.09, Otis skrev:

@bareBård Det var egentlig jævlig kult! Virker det bare ellers mht strømtrekk og at du ikke får feilmeldinger og slikt? Jeg mener at bilen må vite at modulen for fjernkontroll er i bilen ellers kutter den strømmen til denne modulen ved dvale.

Jeg har ikke fått noen advarsler om strømtrekk og avstengning av terminal hittil (fått det på andre ting før).
Arduinoen og CAN-buss-kortet trekker 30-40mA til sammen. Jeg har lest at 80mA totalt gir advarsel.
Planen er å sette dem i standby når det blir stille på bussen og fjerne alle LEDs. Da skal forbruket bli rundt 1mA.
Jeg skal koble på en GSM-modul også. Den drar for mye strøm, så den må jeg sette i standby.

Del dette innlegget


Link til innlegg
Del på andre sider

Joda, Webastoen fungerer fortsatt.

Jeg begynte å fundere litt. Jeg la inn utstyrskode 536 i FA og kodet hele bilen med det. Bilen er altså programmert som om den kom med Webasto fra fabrikk. Men biler som kom med Webasto hedde vel ikke elektrisk tilleggsvarmer?

IHKA-no-PTC.PNG

Nei den har blitt borte.

Når den elektriske varmeren er der kan jeg jo like gjerne bruke den.
I ESYS fant jeg PTC under IHKA. Den stod 'nicht_aktiv'. Jeg endret til 'aktiv'.

IHKA-CAFD.PNG

Mer skulle ikke til, tror jeg. Fitted.

IHKA-PTC-installed.PNG

Bilen var allerede varm da jeg testet, forhåpentligvis var det derfor den elektriske varmeren ikke var aktiv.
Teorien min nå er at den vil varme elektrisk en kort periode til Webastoen kommer i gang. 

Redigert av bareBård

Del dette innlegget


Link til innlegg
Del på andre sider

Jeg ble først litt skuffet, for ved rundt 5°C utetemperatur stod det elektriske elementet fortsatt på 0%.
Jeg begynte å tvile på at trikset fungerte.

Men i dag var det -1°C og da ble det varme. Kos.
670W ekstra i starten for de dagene jeg har glemt å starte Webasto på forhånd.

PTC+i+drift.PNG

Del dette innlegget


Link til innlegg
Del på andre sider

Så bra! Bedre en fra fabrikk tilogmed ☺ Imponert, Godt jobbet! 

Jeg har webasto i begge bilene og bruker det aktivt,  utrolig digg. På Defenderen har jeg montert en gsm styrt releboks . Kunne tenkt meg det samme på E60 men lurer på om det er mer innviklet her siden webastoen er integrert med bilens elektronik.  Selv om varmeren er lik, Thermo tok c.

Del dette innlegget


Link til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være medlem for å legge igjen en kommentar

Opprett en konto

Registrer konto. Det er enkelt!

Registrer en konto

Logg inn

Allerede registrert? Logg inn her.

Logg inn nå


  • Ser på dette akkurat nå   0 medlemmer

    No registered users viewing this page.