Sign in to follow this  
xracer

Lagrede Feilkoder 528i

Recommended Posts

Hei,

Husker ikke dette nå, men lurer på om noen andre husker. Gjelder feilkoder i "shadow memory". Hvis man får en feil som i mitt tilfelle er at ABS/ASC lampene lyser og de tilhørende funksjoner ikke fungerer som de skal. Hvis feilen retter seg når det blir varmere i været, vil da feilkoden som var for dette kunne leses ut med. f.eks INPA ved en senere anledning pga. at den allerede har blitt logget eller slettes alle spor i det systemet fungerer igjen? Og vil feil på en ABS sensor logges. Tenker på for å kunne si om det er ABS modulfeil eller sensorfeil i ettertid.

Share this post


Link to post
Share on other sites

Tror ikke du klarer å se av feilkodene om det er feil på sensor eller ABS hjerne feil. For om hjernen er defekt så tror den at sensor er defekt.

Share this post


Link to post
Share on other sites
On 2/8/2019 at 7:55 AM, Otis said:

Tror ikke du klarer å se av feilkodene om det er feil på sensor eller ABS hjerne feil. For om hjernen er defekt så tror den at sensor er defekt.

Skjønner....det var jo hendig, men generelt, lagrer systemet på bilen alle koder som har oppstått selv om feilen fikser seg selv? Altså en slags historikklogg.

Edited by xracer

Share this post


Link to post
Share on other sites
På 8.2.2019 den 4.15, xracer skrev:

Hei,

Husker ikke dette nå, men lurer på om noen andre husker. Gjelder feilkoder i "shadow memory". Hvis man får en feil som i mitt tilfelle er at ABS/ASC lampene lyser og de tilhørende funksjoner ikke fungerer som de skal. Hvis feilen retter seg når det blir varmere i været, vil da feilkoden som var for dette kunne leses ut med. f.eks INPA ved en senere anledning pga. at den allerede har blitt logget eller slettes alle spor i det systemet fungerer igjen? Og vil feil på en ABS sensor logges. Tenker på for å kunne si om det er ABS modulfeil eller sensorfeil i ettertid.

Du kan om du er litt viderekommen med NCSExpert. Da må du lese ut hele modulen på den rette måten med rett profil og se etter såkalte counters i den evig lange filen du får ut som heldigvis er søkbar. Du må være litt tyskkyndig for å klare det. Hver modul er programmert slik at en feil/feilsignal må være telt XX antall ganger før en feilkode faktisk lagres. Dette fordi elektronikk er "levende" avhengig av spenningskvalitet m.m. og for å unngå falske feilkoder og juletre i cluster hver gang du setter deg i bilen. Om modulen ikke er byttet og eller omprogrammert så skal disse counters / zähler kunne leses ut. Du gjør egentlig litt det samme med INPA men der er mye informasjon filtrert vekk og presentert enklere. Spesielt på lysmodulen er dette en grei måte å sjekke etter problemkabler e.l. ved feilsøking. Du kan lese deg litt opp på NCSExpert og google det. 

Share this post


Link to post
Share on other sites
On 2/18/2019 at 8:24 PM, quandt1960 said:

Du kan om du er litt viderekommen med NCSExpert. Da må du lese ut hele modulen på den rette måten med rett profil og se etter såkalte counters i den evig lange filen du får ut som heldigvis er søkbar. Du må være litt tyskkyndig for å klare det. Hver modul er programmert slik at en feil/feilsignal må være telt XX antall ganger før en feilkode faktisk lagres. Dette fordi elektronikk er "levende" avhengig av spenningskvalitet m.m. og for å unngå falske feilkoder og juletre i cluster hver gang du setter deg i bilen. Om modulen ikke er byttet og eller omprogrammert så skal disse counters / zähler kunne leses ut. Du gjør egentlig litt det samme med INPA men der er mye informasjon filtrert vekk og presentert enklere. Spesielt på lysmodulen er dette en grei måte å sjekke etter problemkabler e.l. ved feilsøking. Du kan lese deg litt opp på NCSExpert og google det. 

Takk for tips! Jeg har egentlig ikke så mye tid til diagnose for tiden, så regner med at jeg etterhvert først bare re-lodder i modulen og sjekker abs sensoren og ser hva som skjer. Tendensen til nå etter å ha hatt problemet i et par uker, er at feilen forsvinner en stund etter oppstart med relativt kaldt motorrom, men etter 10-15 mins kjøring kopler ABS/ASC samt speedometer seg ut permanent til jeg igjen starter opp med rimelig kald motor.. Virker desverre litt som loddepunktene kanskje...

Share this post


Link to post
Share on other sites
5 timer siden, xracer skrev:

Takk for tips! Jeg har egentlig ikke så mye tid til diagnose for tiden, så regner med at jeg etterhvert først bare re-lodder i modulen og sjekker abs sensoren og ser hva som skjer. Tendensen til nå etter å ha hatt problemet i et par uker, er at feilen forsvinner en stund etter oppstart med relativt kaldt motorrom, men etter 10-15 mins kjøring kopler ABS/ASC samt speedometer seg ut permanent til jeg igjen starter opp med rimelig kald motor.. Virker desverre litt som loddepunktene kanskje...

Det kan være det ja, kjent problem på disse. Prøvd isolere modulen? 

Share this post


Link to post
Share on other sites
On 2/20/2019 at 9:17 AM, quandt1960 said:

Det kan være det ja, kjent problem på disse. Prøvd isolere modulen? 

Nei, har ikke gjort det, men kanskje lurt å gjøre etter at jeg evt. har fått fikset den så det ikke skjer igjen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.